Welcome to the Achaea Forums! Please be sure to read the Forum Rules.




  • MorthifMorthif Posts: 1,547Member @@ - Legendary Achaean
    Are you using the default Zulah's gui? Might have to add the size/font size to the capture trigger. 
  • YaeYae Posts: 307Member @@ - Legendary Achaean
    Yeah, you have to fiddle with the font/map size. The way the map works is by sending a new map to the map box. The old map is not deleted, but just pushed up. If your map is a little smaller than expected, you will see part of the old map at the top. 
    Art commissions are closed! I am (practically) dormant.   :s
  • AetheleAethele Posts: 39Member ✭✭✭ - Distinguished
    @Zulah thank you so much for this!!  My work blocked the HTML5 client website but (so far) hasn't blocked the achaea port, so I can still play, but only through a client. I was dreading the switch because HTML5 has so many features that I use. 90% of them are in your GUI, which is amazing. 

    TBS, can anybody help with some really basic troubleshooting for a newb? The directions for fixing rage and chat windows make sense and I think I've made the changes in the alias and trigger windows, but nothing actually changes in the gui. I've tried saving the items, saving the profile, reconnecting all of that. I'm sure there's something really basic I'm just not doing. Anybody know? 

    I'd also like to take out a row of the target buttons and add row that lists my attack hotkeys. I suck at combat anyway, but remembering which F key does which attack (especially for the ones I use less often) is more than I will probably be able to do under pressure. I'm totally willing to throw some credits people's way if somebody could code that for me and I can just download and install it? I'm sure I could figure out basic coding if I tried, but I work a lot and have two kids and it's just not a priority for me. 
  • SkyeSkye The Duchess BellaterePosts: 2,754Member, Seafaring Liason @@ - Legendary Achaean
    did you re-enter the GUI alias? Everytime you make changes and stuff, you can usually reflect the changes nearly instantaneously just entering the GUI alias.

  • AetheleAethele Posts: 39Member ✭✭✭ - Distinguished
    edited July 2016
    I did try that. Now the whole thing won't load!!! Grr.  I keep getting the "I don't understand what this means" response to gui. 
  • YaeYae Posts: 307Member @@ - Legendary Achaean
    Usually that means something broke. :sweat_smile:
    Art commissions are closed! I am (practically) dormant.   :s
  • SkyeSkye The Duchess BellaterePosts: 2,754Member, Seafaring Liason @@ - Legendary Achaean
    okay is it just one 'I don't understand what this means'?

    Cause that means in the process of saving your stuff, you accidentally de-activated the alias. Make sure the checkbox next to the gui alias is ticked.

  • ZulahZulah Posts: 761Member @ - Epic Achaean
    edited August 2016
    Looks like some people ran into 1 of 2 issues with this mapper.

    Problem 1: Map is blank nothing showing
    Solution 1:
    -Load up a blank or map working profile.
    -Update the map
    -click mudlet SETTINGS --> MAPPER ---> Copy map to another profile.
    -Select the profile you use this GUI on having map problems and copy to it.

    Solution 2:
    -In this GUI in SETTINGS --> MAPPER --> Load another map file in: Pick map file.
    -Select a map from another profile (usually in, C:\Users\Owner\.config\mudlet\profiles\xxxx\map\)

    Problem 2: Can't click on map to zoom in or out.
    -Select SCRIPTS
    -Search for --> Sea Mapping Window
    -In this script you will find a function called mapswap()
    -You will have to add 2 lines to the code: seamapperbg:show() and seamapperbg:hide()

    function mapswap()
    if gmcp.Room.Info.environment == "Vessel" then
    mapContainer:move(9000, nil)
    zulahshipmode = 1
    mapContainer:move(0, nil)
    zulahshipmode = 0

    If anyone has other questions or problems I am more available now to answer!
  • ZulahZulah Posts: 761Member @ - Epic Achaean
    Version 2.0 nearing release...
  • GamoneterikGamoneterik Posts: 118Member ✭✭✭ - Distinguished
    Absolutely amazing. Started looking at Akayan's thing and then a bunch of other stuff, realised it used Vyzer which people told me sucks, kinda put the GUI project on halt whilst I wondered if I would have the Strength to code it myself, then installed this. A couple of fixes for a few things, and it is just the absolute perfect gui for me.

    I love that the code is easily customisable because it is well organised and clearly written, with comments etc.
    This is one reason I opted not to download the beta for 2.0 - just glancing at the first page of that post I saw it has customisation by clicking aka. Akayan's thing. Not for me, but man - I am with you all the way on this project. Top job, you will have donations from me surely, if I ever have credits again.

    Thanks @Zulah you are a Code God!
    "To thine own self be true."
  • VercioVercio Posts: 50Member ✭✭✭ - Distinguished
    How can I add a box for limb tracking? I saw that Alaskar mentioned it earlier on this thread, But. I couldn't find an explanation of how to do so.
  • VercioVercio Posts: 50Member ✭✭✭ - Distinguished
    Yae said:
    Since Garadross is showing his, I thought I'd show mine with a few resources!

    Added: (Click the names to go to the resource page!)
    People Tracker (thanks to Klendathu, used with svo)
    Room Info (thanks to Valden)
    New Tab on Chat Tab (look at the script and copy/paste/edit the other tabs' codes to make a new one)
    GMCP functions on Chat Tab (mostly thanks to Cynlael, be sure to look at Kasya's post tho)
    Druid W P V (Wildgrowth/Panacea/Vigour geyser box, just based off of svo defence tracking)
    Sunlight Tracker (thanks to Eilona, ask her yourself if you want it)
    Metamorphosis GMCP Tracker (code here with help from Firien)
    Limb Counter (thanks to Titonus, requires svo and needs a bit of adjustment)
    Svo Do-Repeat Checker (based off svo stuff)

    A few targets since I didn't really need that many.
    Fixed a few issues tiny issues with elist tracker.
    Changed the color of the HP/MP bar
    Added the sixth battlerage bar
    Added news/messages track
    Unseen, but made the sea mapper track return gmcp.Room.Info.environment=='Vessel' instead of just triggers.
    How did you get your target tracker to look like that? and over there.
  • AlaskarAlaskar Posts: 393Member ✭✭✭ - Distinguished
    How can I fix this? 

    It's like it's doubled up, and the ship is always in the top half of the map. I downloaded the sea mapper thing above and replaced the original Zulah one, and got this. The original had single line spaces in the map and always had the ship at the very top border.

  • AlaskarAlaskar Posts: 393Member ✭✭✭ - Distinguished
    Ignore that, fixed it.

  • TorinnTorinn Posts: 953Member ✭✭✭✭✭ - Grand Achaean
    edited February 2017
    How did you fix it @Alaskar ?
    Deucalion says, "Torinn is quite nice."
  • AlaskarAlaskar Posts: 393Member ✭✭✭ - Distinguished
    Downloaded the script mentioned on the last page and deleted a duplicate folder that I missed when I copied this profile onto this computer. 

  • KurnsKurns Posts: 1Member
    I loaded up the GUI, and typed GUI but after I did, the map stopped loading entirely, Is there a command to make this this loads?
  • SixtusSixtus Posts: 8Member
    How do you zoom in on the map? I tried:



    but this doesn't work.

  • AccipiterAccipiter Posts: 346Member ✭✭✭ - Distinguished
    Try the scroll wheel the opposite way that you would think would scroll it? It works on mudlet usually.
  • SixtusSixtus Posts: 8Member
    I was hoping to automate this.
  • VadimusesVadimuses Posts: 1,083Member @ - Epic Achaean
    That should work - are you in 2D view?
  • SixtusSixtus Posts: 8Member
    I ended up deleting the sea mapper code from the GUI, then creating a function that runs the setMapZoom and centerview code upon login. Adding in the map code to the ^gui$ alias didn't work for some reason. It isn't pretty but I don't feel like troubleshooting it any more.
  • SixtusSixtus Posts: 8Member
    I tried adding --cecho("scorebox", "<white>Karma: <gold>"..gmcp.Char.Vitals.charstats[3]:sub(8).." ") to the updateScoreBox() function, but it seems to break the GUI. The GUI only partially loads. Rerunning the gui alias works though, which is strange.
  • TorinnTorinn Posts: 953Member ✭✭✭✭✭ - Grand Achaean
    edited July 2017
    Never mind.
    Deucalion says, "Torinn is quite nice."
  • KoganKogan Posts: 401Member ✭✭✭✭ - Eminent
    edited July 2017
    @Sixtus Centerview requires a room # passed as an argument. Try something like -- centerview(gmcp.Room.Info.num) -- if you're trying to center the map on yourself.
  • SixtusSixtus Posts: 8Member
    Sixtus said:
    I tried adding --cecho("scorebox", "<white>Karma: <gold>"..gmcp.Char.Vitals.charstats[3]:sub(8).." ") to the updateScoreBox() function, but it seems to break the GUI. The GUI only partially loads. Rerunning the gui alias works though, which is strange.

    I had to remove all references to the sea mapper code and that fixed it.
Sign In to Comment.