Welcome to the Achaea Forums! Please be sure to read the Forum Rules.

Mudlet Mapper mmp.settings.echocolour problem

TeshaTesha Member Posts: 3,006 @@ - Legendary Achaean
edited September 2019 in Tech Support

I updated the mapper script and goto broke. I figured out why. On line 543 it referred to

"<" .. mmp.settings.echocolour .. ">" .. mmp.speedWalkPath[#mmp.speedWalkPath],

However, there was no mmp.settings.echocolour. So attempts to set it via the built-in vlua mmp.changeEchoColour("orchid") didn't work because it was trying to change a nil variable - at least from what I could tell from the errors. I tried to fix it by just doing vlua mmp.settings.echocolour = "orchid" - but that didn't work. So I figured out it sent that as a custom option, and finally came up with the solution of making line 543 this:

"<" .. mmp.settings._customOptions.echocolour .. ">" .. mmp.speedWalkPath[#mmp.speedWalkPath],

This fixes 'goto', but it mmp.settings.echocolour is called in many different places. I've tried vlua createOptionsTable to establish the variable and then change it properly but that didn't work either.

Any ideas how to get mmp.settings.echocolour set? Please help!

 i'm a rebel


  • QwindorQwindor Fort RileyMember Posts: 153 ✭✭✭ - Distinguished
    Ok I know I am extremely late on this but can you go to the github repo for the mapper and put in an issue please if it is still a problem.

Sign In to Comment.