Welcome to the Achaea Forums! Please be sure to read the Forum Rules.

Error Messages on Mudlet Profile on Chromebook (using built-in Linux)

ZackeryZackery Member, Secret Squirrel Posts: 279 ✭✭✭✭ - Eminent
edited July 2019 in Client Help
Hello people smarter than me,

I recently installed Mudlet on my Chromebook, using the built-in Linux feature. I tried to load up my existing profile and am receiving a lot of error messages. I don't know how to interpret these - is anyone able to give me an idea of what is going wrong? Here is the error log:

https://ada-young.appspot.com/pastebin/NIWIueZC

Thank you!

ETA: Please respond as if you are explaining this to your grandfather - or maybe just dad. My knowledge and understanding in this area is very limited.

Comments

  • MishgulMishgul Trondheim, NorwayMember Posts: 5,378 @@ - Legendary Achaean
    I'll send you a PM but I think the problem is that you forgot to get your svo file and put it in the right location. Looks like mudlet cannot find it at least.

    -

    One of the symptoms of an approaching nervous breakdown is the belief that one's work is terribly important

    As drawn by Shayde
    hic locus est ubi mors gaudet succurrere vitae
    Zackery
  • ZackeryZackery Member, Secret Squirrel Posts: 279 ✭✭✭✭ - Eminent
    Aha! I thought the file structure was weird because I was on a Chromebook, but I just didn't remember to do view hidden files. I might have to bug you to make sure I'm in the right directory, but I'm picking up what you're putting down.
  • AntoniusAntonius Member Posts: 5,040 @@ - Legendary Achaean
    It looks more like an issue with the Mudlet installation. The first error mentions that 'lfs' is a nil value; lfs is the Lua file system library, which should be loaded by Mudlet when it starts up. I can't help more than that though.
  • ZackeryZackery Member, Secret Squirrel Posts: 279 ✭✭✭✭ - Eminent
    edited July 2019
    Thank you! It does look like the problem is with Lua (I've also changed a stupid mistake since the first post, so I think this is the squeaky wheel now). My thought is maybe I need to install Lua and LuaFileSystem myself? I keep running into this when I try, though:



    Sorry to ask 8million questions, but any idea what I should do?
  • DragonknightDragonknight MhaldorMember Posts: 286 ✭✭✭✭ - Eminent
    Yea, hop on the mudlet discord and see if any of them have tried it. Probably have better, or at least quicker, luck getting answers there.
  • ZackeryZackery Member, Secret Squirrel Posts: 279 ✭✭✭✭ - Eminent

    Thank you! Vadi helped me out - turns out I was using a very old version of Mudlet because I was lazy and just did sudo apt-get install mudlet instead of downloading the official version.

    Here is what ended up working for me, if anyone else is trying to set up Mudlet on a Chromebook:

    Enable Linux (beta) on your Chromebook.
    Note: This may not be supported on older Chromebooks.

    1. At the bottom right, select the time. 
    2. Select Settings.
    3. Under "Linux (Beta)," select Turn On.
    4. Follow the steps on the screen. Setup can take 10 minutes or more.

    Download the latest version of Mudlet.

    1. Open https://www.mudlet.org/download/.
    2. Click the Ubuntu tab and download the .tar file.

    Install Mudlet.

    1. Extract the AppImage by opening Terminal and entering:
      tar -xvzf Mudlet-3.22.1-linux-x64.AppImage.tar
      Note: modify the above to reflect the file name of the version downloaded.
    2. Make the file executable:
      chmod u+x Mudlet.AppImage
    3. Execute Mudlet:
      ./Mudlet.AppImage
      Note: Do not close Terminal while Mudlet is running.


    To load an existing profile, add the profile folder to ~/.config/mudlet/profiles. Make sure it is unzipped. It will then be available when you open Mudlet and Connect.

    MaajidaVadimuses
Sign In to Comment.