Installing Mudlet on Sparky Linux(Debian based)

I’ve installed Sparky Linux (Debian based) on my very old computer (Asus EEE PC 1000HE). Tried many linux distros before but this one is the fastest for me. But the Mudlet version in Debian repositories is out of date. So I have to install it manually. I tried to download it from mudlet website but I can’t open AppImage file.(I made it executable from permissions) So I downloaded latest version from GitHub. That’s not an AppImage file, but it needs to be installed. I’ve tried the instructions in this web site

But when I try to do this one: sudo luarocks install lua-yajl


Error: Could not find library file for YAJL

No file libyajl.a in /usr/lib

No file libyajl.a in /usr/lib/x86_64-linux-gnu

No file in /usr/lib

No file in /usr/lib/x86_64-linux-gnu

No file matching* in /usr/lib

No file matching* in /usr/lib/x86_64-linux-gnu

You may have to install YAJL in your system and/or pass YAJL_DIR or YAJL_LIBDIR to the luarocks command.

Example: luarocks install lua-yajl YAJL_DIR=/usr/local

And other steps in web site don’t work because of this error. I’m stuck and I don’t know what to do. I’m a beginner linux user and don’t know anything about this code and command things. I prefer linux because it’s safer and faster then windows. Especially on very old computers like mine. Is there any easy way to install Mudlet? Anyone able to help me?


  • It may simply not be in the repo for that distribution, or you haven't done 'sudo apt-get update' beforehand (in reference to lua-yagil). I've never had to compile Mudlet from source as the AppImage file has always worked fine for me, but not all Debian-based distros are equal, sadly. I would also ask if you've done 'sudo apt-get build-essential' as that has packages necessary for compiling source code. I can look into it more later.
  • I've thought that Debian repositories have very old version of Mudlet. Because it says like that on download section of the official website. AppImage is not working for me because it's for 64bit. My old computer is 32bit. But a few minutes ago I searched mudlet on synaptic package manager and saw that repositories have version 3.0.0 and that is enough for me. It says version number is 1:3.0.0. So I thought that it is very old and I didn't even download it.  :) Thanks for your help. 
  • We'd love to have a Debian maintainer update the package for us. This is something out of our control.
  • edited July 2019
    It should work using the following:
    YAJL_PATH="$(pkg-config --variable=libdir yajl)"
    luarocks install lua-yajl YAJL_LIBDIR="${YAJL_PATH}"
Sign In or Register to comment.