Welcome to the Achaea Forums! Please be sure to read the Forum Rules.

Mudlet 3.11 - quality improvements all around + autosave!

VadimusesVadimuses Posts: 1,089Member @ - Epic Achaean
This northern summer we've focused on adding some long-standing feature requests and improvements to Mudlet. Enjoy!
 

New feature - expiring triggers

You can now make temporary triggers expire after a firing a certain amount of times, 4 times in this example:
tempExactMatchTrigger("You have recovered balance on all limbs.", 
  function() echo("Got balance back!\n") end,
4)
You can also have a trigger avoid counting when it fired towards expiration by returning true.  This example will match the prompt 2 times, unless the prompt is "55 health."
tempPromptTrigger(function()
  if line == "55 health." then return true end
end, 2)
All trigger types support this new functionality added by vadi2, so check the manual for more examples.
 

New feature - profile autosave

Building on the earlier work that made profile saving quicker, vadi2 added profile autosave to Mudlet. It'll save your work every 2 min, so in case of a sudden computer shutdown or anything else, not having saved the profile won't result in hours of work lost. This feature is efficient and it'll create just one backup for autosave.
 
Auto-saved profiles will appear with a small icon in the list:
 
 

Signed Windows installer

We've put out a call for donations last October to help us raise funds so the Windows installer can be "signed" - and we're like to thank the community, especially Iron Realms for answering the call.

The Windows installer looks a lot better now and will be less of a hassle with anti-virus protection!


Long-time Mudlet user and want to donate? You can!

Translation efforts

While we're still working on getting translations people have done back into Mudlet, we'd like to shout out to all of the people who volunteered to translate Mudlet into their language on Crowdin:
    
Alessio Albertoni (a.albertoni), Bartłomiej Fraszczyk (bartek.fraszczyk), comisat, dermox, eblisade, eckol, Eric Oestrich (oestrich), Evan (evan.dorpsgek), Faenriis, Hagalnae, heypnus, Héctor Luaces (mordisko), Iacopo Fontanelli (uccio79), Kae (itsTheFae), keneanung, Leris, lrvy, madpuppy, Marco Tironi (wiploo), Mikhail Balanov (realsonic3), mtirado1, Stephen Lyons (SlySven), Vadim Peretokin (vperetokin), Vlad Kasantsev (vladkasantsev), and Игорь Антонов (antigr16).
 
Special thanks to Leris who has been coordinating translation efforts, as well as TheFae who is helping the infrastructure.
 

Starting new maps

If you're using a mapping script tailored for your game, starting a new map would be easy, or you'd even have a map available to you for use already. If you aren't, though, and you'd like to map the game out by hand, things are a little difficult.
 
This release vadi2 added a right-click option on the blank map area that allows you to either load a map or create a new one right away:
 
 

Bugfixes

The new logging settings will now correctly save and single-line copy won't add blank spaces at the start (while multi-line copy will, to preserve nice alignment). Profile notes will now also get saved correctly when you just close one profile - previously, they saved when you closed entire Mudlet. Thanks to SlySven for doing this work.
 
All in all, there have been 1,002 contributions (PRs) to Mudlet since we moved to Github! It's a bit of a milestone for us and you too can join in to improve Mudlet! 88% of those PRs have been merged,
 

Credits

Thanks to basooza, keneanung, Leris, SlySven, and vadi2 for the code improvements in this release!
 

Changelog

  • added: expiring temporary triggers
  • added: getGridMode()
  • added: profile autosave
  • added: toggle for show icons in menus
  • added: windows installers are now signed (less problems with AV installing/upgrading)
  • fixed: changing main window background will apply changes immediately
  • fixed: logging settings are now saved correctlyfixed: single-line copy won't introduce blank spaces
  • fixed: notepad will save when just one profile is closed
  • improved: Lua error messages are more intuitive now for selectCurrentLine(), isAnsiFgColor(), isAnsiBgColor(), getFgColor(), getBgColor(), wrapLine(), selectCaptureGroup(), getLines(), getCurrentLine(), and echoPopup()
  • improved: Mudlet now sends a correct response for MXP <supports>
  • improved: You can now create new maps by right-clicking on the empty map
  • infrastructure: updated 3rd party dependencies on windows

Tagged:

Comments

  • AntoniusAntonius Posts: 4,594Member @@ - Legendary Achaean
    Vadimuses said:
    single-line copy won't add blank spaces at the start (while multi-line copy will, to preserve nice alignment).
    This decision baffles me. Is this functionality when copying text that spans multiple lines something somebody actually requested?

    If I highlight some text, and then copy it, I just want what I have highlighted copied to my clipboard. If I wanted something else copied, I'd have highlighted something else. Adding whitespace "to preserve nice alignment" (for what?) just adds an additional step where I have to delete that whitespace myself.
    SobriquetKayeil
  • VadimusesVadimuses Posts: 1,089Member @ - Epic Achaean
    Well - the idea was that if you're copying many lines, you'd want the first one aligned like you see it on the Mudlet screen.

    Happy to take feedback on the idea!
  • PyoriPyori Posts: 908Member ✭✭✭✭✭ - Grand Achaean
    I feel like having that a toggleable option would be a lot better...

    I agree with Antonius, honestly.

  • AntoniusAntonius Posts: 4,594Member @@ - Legendary Achaean
    I can't think of a situation where I'd ever want that. If I'm copying something for a log, I'd usually start from the beginning of the line so there'll be no added whitespace anyway. If I'm not copying from the beginning of a line, there's a reason I'm excluding the beginning. If I'm creating a substring trigger, the whitespace screws that up. If I'm posting it elsewhere, I'm probably not going to want the whitespace either because it will look weird.

    Maybe there's a niche usage for it, in which case it seems like it might make a useful option on the right-click context menu (similar to the Copy HTML option), but having it as the default is awful.
    Kayeil
  • IsmayIsmay Posts: 607Member ✭✭✭✭✭ - Grand Achaean
    Just wanted to say that the contributions you’ve made to this community have done much more than anyone realizes to help make IRE a success. I know that if it weren’t for svo and the earlier incarnations, I would never have stuck around for all these years. This sentiment is shared by many!
  • RispokRispok Posts: 700Member ✭✭✭✭✭ - Grand Achaean
    Looks like some good stuff!

    I just noticed that on mac 10.13.4 using this newest mudlet 3.11, I can't resize the map window (totally default map window display, not a fancy coded kind in scripts). I seem unable to manipulate it with the cursor at the sides to change the size. Never seen this before, so I assume it's an accidental change.

    I agree with thoughts on the whitespace thing, though. It seems like something I wouldn't want enabled by default.
  • JadysJadys Posts: 205Member ✭✭✭✭ - Eminent
    Loving the support and work that goes into the upgrades! I was a bit bummed though to log into the new mudlet today to find my gui jumbled. :(
  • RispokRispok Posts: 700Member ✭✭✭✭✭ - Grand Achaean
    In addition to the map not being able to resize, whenever trying to export a package, as soon as I hit 'export' it instantly crashes and closes the program. Not just once, every time that I click export.
  • PyoriPyori Posts: 908Member ✭✭✭✭✭ - Grand Achaean
    Rispok said:
    In addition to the map not being able to resize, whenever trying to export a package, as soon as I hit 'export' it instantly crashes and closes the program. Not just once, every time that I click export.
    This is a known issue, I reported it a couple of weeks back but apparently it was too late to make the release build this time around. I just get around it the old fashioned way, of exporting aliases/triggers etc individually, then putting them in a zip file.

  • ZerisZeris Posts: 57Member ✭✭ - Stalwart
    edited July 18
    The save button now activates if I just roll over it, rather than clicking on it. It's not annoying or anything, just reporting the weirdness.

    ETA: it actually seems to do it randomly if I move my mouse off of the trigger editor or back onto it from anywhere else on the screen.
  • SkyeSkye The Duchess BellaterePosts: 2,774Member, Seafaring Liason @@ - Legendary Achaean
    edited July 20
    okay uh... I'm gonna tag @Zulah on this because it's his bit of code. I'm basically using a modified version of his original free GUI from way back. I'm also not sure if this started with 3.11.1 or 3.11.0 because I've been pretty absent the last few days. I'm leaning towards the former though.

    Something seems to have gone horribly wrong... It started small at first:


    I just noticed this weird little black box behind my rage meters.... Then I tried to lesserform...


    Holy shit. And it stays that way. The same thing also happens if I go from lesserform to dragon.


    I can live with the little black box, but I can't live with this mess. I don't really know where to begin to troubleshoot the weird black box, but I'm gonna pastebin the code that generates the GUI, and the debug log, if someone can help me figure this out. I saw a couple of errors, but I'm not sure if they're the only reason why this is happening.


  • SkyeSkye The Duchess BellaterePosts: 2,774Member, Seafaring Liason @@ - Legendary Achaean
    ok, panic attack aside, I didn't manage to fix it, but I did manage to bypass the problem. I'm not sure why it suddenly decided to stop working.

    The alias is used to initialise the GUI when the client starts up. It is also used to refresh the GUI for any changes that have been made. Up until now, I've had no issues using the alias wholesale for swapping between lesser/greater forms.

    Now, for some reason, the alias will completely mess up the layout when used to refresh the GUI. It works fine when I've just opened mudlet though.

    I wound up bypassing the problem by picking out only the relevant functions to update, which I'm sure everyone will say is what I should've done in the first place. But I can't get to the heart of the issue of why this even started happening at all :x

    I don't participate in PVP or do a lot of client-side tinkering, so I haven't touched anything on the backend in weeks except to change a couple of unrelated aliases.

    The other thing is that mysterious black box that appears behind the Battlerage timer bars. It appears when the GUI is initialised, but when I switch between greater/lesser form, it disappears. The frame around my mapper box also disappears, for that matter, but none of the other boxes.


  • ZulahZulah Posts: 761Member @ - Epic Achaean
    @skye you can fix that screen size issue by entering 2 lines worth of text into the command line.

    Example: aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa

    Yes I know this sounds odd but as soon as the command line bumps into 2 lines it will fix everything. Tested this with a number of people so far and it's worked. It's an issue with getMainScreenSize() or however it's called thinking you have a smaller resolution than you do
    Skye
  • ZerisZeris Posts: 57Member ✭✭ - Stalwart
    Whenever I try to export a script via the toolbox, Mudlet crashes. The export works fine, but Mudlet just dies afterward.
  • PyoriPyori Posts: 908Member ✭✭✭✭✭ - Grand Achaean
    Zeris said:
    Whenever I try to export a script via the toolbox, Mudlet crashes. The export works fine, but Mudlet just dies afterward.

    Pyori said:
    Rispok said:
    In addition to the map not being able to resize, whenever trying to export a package, as soon as I hit 'export' it instantly crashes and closes the program. Not just once, every time that I click export.
    This is a known issue, I reported it a couple of weeks back but apparently it was too late to make the release build this time around. I just get around it the old fashioned way, of exporting aliases/triggers etc individually, then putting them in a zip file.



  • VeldrinVeldrin DenmarkPosts: 393Member ✭✭✭✭ - Eminent
    Zulah said:
    @skye you can fix that screen size issue by entering 2 lines worth of text into the command line.

    Example: aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa

    Yes I know this sounds odd but as soon as the command line bumps into 2 lines it will fix everything. Tested this with a number of people so far and it's worked. It's an issue with getMainScreenSize() or however it's called thinking you have a smaller resolution than you do
    Yeah, in my case when I start mudlet up it claims I use a 1600 resolution instead of the 1900 so all my windows are screwed up too, eventually it'll figure it out and then you can run the init scripts again and use moveWindow for labels that won't move and then it's all fixed. It's bloody annoying though
    image
  • ZerisZeris Posts: 57Member ✭✭ - Stalwart
    I'm also getting weird af line breaks.

    This is with all triggers/scripts/etc turned off. When I have the option to fix unnecessary line breaks turned on, the exits get mushed up into the room items, but neither on nor off fixes the random newline after the room name.

    Postal Office of Hashan (indoors).
           
    A runic totem is planted solidly in the ground. There are 2 spectres of the Shadow Court here. A knight of the Atrament
    guards the area, hands poised on the pommel of a broadsword. A mounted tsalmaveth watches this area carefully. A hooded
    nocturni, crackling with blue streaks of electrical discharge, patrols this area. An obsidian eye sigil is here. A
    shimmering orb lies here, illuminating the surrounding area with a slight glow. A noble hippogriff flaps its wings in
    agitation here.You see a single exit leading northwest.

    Postal Office of Hashan (indoors).
    A runic totem is planted solidly in the ground. There are 2 spectres of the Shadow Court here. A knight of the Atrament
    guards the area, hands poised on the pommel of a broadsword. A mounted tsalmaveth watches this area carefully. A hooded
    nocturni, crackling with blue streaks of electrical discharge, patrols this area. An obsidian eye sigil is here. A
    shimmering orb lies here, illuminating the surrounding area with a slight glow. A noble hippogriff flaps its wings in
    agitation here.
    You see a single exit leading northwest.

    Postal Office of Hashan (indoors).
           
    A runic totem is planted solidly in the ground. There are 2 spectres of the Shadow Court here. A knight of the Atrament
    guards the area, hands poised on the pommel of a broadsword. A mounted tsalmaveth watches this area carefully. A hooded
    nocturni, crackling with blue streaks of electrical discharge, patrols this area. An obsidian eye sigil is here. A
    shimmering orb lies here, illuminating the surrounding area with a slight glow. A noble hippogriff flaps its wings in
    agitation here.You see a single exit leading northwest.

    Postal Office of Hashan (indoors).
           
    A runic totem is planted solidly in the ground. There are 2 spectres of the Shadow Court here. A knight of the Atrament
    guards the area, hands poised on the pommel of a broadsword. A mounted tsalmaveth watches this area carefully. A hooded
    nocturni, crackling with blue streaks of electrical discharge, patrols this area. An obsidian eye sigil is here. A
    shimmering orb lies here, illuminating the surrounding area with a slight glow. A noble hippogriff flaps its wings in
    agitation here.You see a single exit leading northwest.


  • MathildaMathilda Posts: 877Member ✭✭✭✭✭ - Grand Achaean
    @Zeris Check if your ingame CONFIG WRAPWIDTH is set to 0. That essentially means you are delegating all wrapping to Mudlet. Your issue looks like what would happen if your Mudlet wrap is shorter than your Achaea wrap.
     <3 
  • ZerisZeris Posts: 57Member ✭✭ - Stalwart
    Yah, it's 0.
  • KayeilKayeil Washington StatePosts: 2,819Member @@ - Legendary Achaean
    Trying to save a copy of my profile and now mudlet isn't responding, just completely frozen.
    What doesn't kill you gives you exp.

  • VenderVender Posts: 258Member ✭✭✭ - Distinguished
    Import export and save profile as buttons don't seem to be working either. And I still can't PgUp or PgDn to scroll like I used to.
    it's frustration that creates desire
    not the other way around
    unless you let it
    baby, I'll let it
  • TahquilTahquil Posts: 4,035Member @@ - Legendary Achaean
    So uh... My triggers have gone. Half are still working despite being invisible. Alias etc. still showing up per normal.

  • RangorRangor Posts: 3,138Member @@ - Legendary Achaean
    edited August 10
    Tahquil said:
    So uh... My triggers have gone. Half are still working despite being invisible. Alias etc. still showing up per normal.

    What did you do tahquil!?
    image
  • PyoriPyori Posts: 908Member ✭✭✭✭✭ - Grand Achaean
    I ran into that bug a few times when I deleted some things. Usually restarting, or reverting to a previous save fixes it. Dunno what actually causes it in the first place, though.

    Tahquil
  • TahquilTahquil Posts: 4,035Member @@ - Legendary Achaean
    Reverting to previous save worked btw.
Sign In to Comment.