Welcome to the Achaea Forums! Please be sure to read the Forum Rules.

alias on body part

RoveldaRovelda Member Posts: 121 ✭✭✭ - Distinguished
I have tried to find an example, but have not seen any. Can someone correct this for me, please? 


send("pommelstrike " ..target .. " ;legslash " ..target .. " [right]")

Comments

  • IocunIocun Member Posts: 3,695 @@ - Legendary Achaean
    Why do you have "[right]" in square brackets?
    Other than that, it looks fine, but will only work if you have set the semicolon to be your command separator in your preferences. I generally recommend avoiding issues with that by explicitly sending it as two commands:

    sendAll("pommelstrike " ..target, "legslash " ..target .. " right")
    Rovelda
  • RoveldaRovelda Member Posts: 121 ✭✭✭ - Distinguished
    I invented that part. :D I saw somewhere something similar, but in a different language. Thank you so much, Iocun! :)

    By the way, I am not using sendAll and it is working with more than one command, but I will copy this one as you said.
  • IocunIocun Member Posts: 3,695 @@ - Legendary Achaean
    Normal sends can only send a single thing, typically. If yours allows you to send multiple things, given as separate arguments, you must have something in your scripts that overwrites the default send function. (By default, the second argument of send serves to set whether you wish the sent command to be echoed or not.)
    Rovelda
  • JacenJacen Member Posts: 2,325 @@ - Legendary Achaean
    If you have svo, you can use $ instead of ;. I actually use ;; as my command separator so that I can "smile with a wink" IG. Ideally though, you'd rather split it up and use the sendAll function
    image
    Rovelda
  • RoveldaRovelda Member Posts: 121 ✭✭✭ - Distinguished
    It is not working :( It only does the first part. 

    Can you paste yours for me, Jacen? To try it with $
  • RoveldaRovelda Member Posts: 121 ✭✭✭ - Distinguished
    edited December 2012
    The problem is that if I try it on myself, I see twice "I do not recognise anything called that here." and it has always had...


    Does it simply mean that it is very possible that my second attack will miss on others and it doesn't show as a miss?


    Iocun, when I do it in my style, I see it like this in the game:

    pommelstrike Rovelda ;strike Rovelda knees


    In your style, I see it like this:

    pommelstrike Rovelda
    armslash Rovelda left



    The difference is that I had it separated with the ; inside the "", like:

    send("pommelstrike " ..target .. " ;strike " ..target.. " knees")



  • RoveldaRovelda Member Posts: 121 ✭✭✭ - Distinguished
    I've now tried on someone smaller than me, and the same happens: I see the second attack in the command, but it does not take effect. Could LAG be a reason?
  • RoveldaRovelda Member Posts: 121 ✭✭✭ - Distinguished
    edited December 2012
    I was trying that combo because a Blademaster told me to, but there must have been some confusion. Another blademaster explained now to me that that combination is not possible.

    Thank you again. :)


    The right/leg part will still be very useful to me!
Sign In to Comment.