Welcome to the Achaea Forums! Please be sure to read the Forum Rules.

Mudlet 3.0.1 available

VadimusesVadimuses Posts: 1,079Member @ - Epic Achaean

A quick bugfix release to 3.0.0 - if you haven't upgraded before, now's the time!

Search visible by default

(click to play gif)

Search area is now visible by default again, similar to how it was in 2.1. The redundant 'Search' button was removed to save space on smaller screens and a new collapse/expand button is in place.

Experimental map formats enabled

You can now choose to save your maps in versions 17 and 18 in Preferences > Special Options. Technically speaking, you could choose to save your maps in 3.0.0 in newer formats as well, but it then wouldn't be able to load them - now it can.

Map format 17 allows you to use map and area user data functions - similar to room userdata that was available already. See searchAreaUserData()setAreaUserData()clearAreaUserData()clearAreaUserDataItem()getAreaUserData(), getAllAreaUserData(), setMapUserData(), clearMapUserData()clearMapUserDataItem()getMapUserData()getAllMapUserData().

Map format 18 will save your players location when copying maps to other profiles.


Other improvements include:

  • southwest exit can now be cleared in room exits dialog
  • settings are no longer stored in Mudlet and mudlet in case-sensitive filesystems
  • variables ticked to be saved in the Variables view will no longer crash Mudlet for profiles that use autologin


  • MorthifMorthif Posts: 1,547Member @@ - Legendary Achaean
    search now takes a few seconds and acts like it is going to crash mudlet. (spinny cursor fade)
  • AustereAustere TennesseePosts: 2,191Member @@ - Legendary Achaean
    Morthif said:
    search now takes a few seconds and acts like it is going to crash mudlet. (spinny cursor fade)
    I noticed this on 3.0.0 yesterday, so it might not be a new issue.  Been happening ever since
  • CoamenelCoamenel Posts: 188Member ✭✭✭ - Distinguished
    Morthif said:
    search now takes a few seconds and acts like it is going to crash mudlet. (spinny cursor fade)
    Search has always done that on my clients. 2.1 did it, 3.0delta did it, 3.0 final does it.
  • AnnekeAnneke Posts: 16Member
    I haven't updated... could this be the reason Mudlet is suddenly not as quick to respond to commands and takes for ever to load and connect? Also, I tried to see if the mapper needed to be updated, clicked update, it said downloading and just... never updated or downloaded anything, so I forced it, now my map is ugly and harder to read. Tried reinstalling, still the same. Also, when I uninstall the mapper script Mudlet stops responding for about a minute, and the same when I try to install it, and when I'm closing the client all together. Ideas please? Or just update?
  • VadimusesVadimuses Posts: 1,079Member @ - Epic Achaean
    Kind of strange but try!
  • AnnekeAnneke Posts: 16Member
    Updated, had some errors, has all been fixed after updating the svof and mapper again with recent fixes. Thank you.
Sign In to Comment.