mudlet mapper gone screwy

This happened after the latest crowdmap update...

(mapper): Room: Before the gate of Ashtan #: 1284 area: Central Wilderness (22)
(mapper): Coordinates: x:-28, y:29, z:0, locked: nope, weight: 1
(mapper): Environment: Road (12)
(mapper): Exits (2):
  south -> The approach to Ashtan (1285)
  north -> Entering the main gate of Ashtan (436) (in Ashtan, the City of)
(mapper): Special exits (2):
  script:sendAll("wear wings", "say *ashtani duanathar", "remove wings", false) 
-> On the clouds (3885)
  script:sendAll("wear wings", "say *ashtani duanatharan", "remove wings", 
false) -> High above the clouds (4882)
(mapper): Stuff you can do:
  Clear all labels (in area) (whole map)
  Check for mapper & map updates (force map)
(mapper): version 15.7.1.

It keeps trying to wear wings and say Duanathar from anywhere near the gates of Ashtan...


  • That's weird, if I go to clouds and try to go anywhere, it removes my wings and walks me into a totem. It's pretty nice.
    Replies the scorpion: "It's my nature..."
  • Go to that room, do MC ON, SPE CLEAR, MC OFF. 
  • All fixed! Thanks!
  • edited February 2016
    Just going to piggy back here instead of starting another thread...

    I updated my mapper scripts today and I'm receiving the following errors:

    (mconfig entered here)
    [ERROR:] object:<Option> function:<Alias1580>
             <[string "function Alias1580()..."]:3: attempt to index field 'settings' (a nil value)>

    (on login)
    [ERROR:] object:<event handler function> function:<mmp_checkupdatestart>
             <[string "function mmp_checkupdatestart(...)..."]:2: attempt to index field 'settings' (a 
    nil value)>

    I have uninstalled and reinstalled several times, wiped out every map file and reinstalled, etc.

    Any thoughts? Only became an issue today. I downloaded the file from the Mudlet Mapper website.

  • Honestly, knowing absolutely nothing about the mapper,  try finding the file that stores your settings for mapper and delete it.  Should be in .config
  • Did that. Wiped it a few times now.

  • Dunn said:
    Did that. Wiped it a few times now.
    Again, Not a mapper expert here, so sorry if this is wrong:

    Is lua mmp.settings returning anything?   Honestly, the first error makes sense if that table isn't being populated.  You might also want to check lua getMudletHomeDir() as well to make sure it's linking to the right spot.  I can't find anything really on the second error. 
  • edited February 2016
    Just messing with it this morning... found an old copy of my system from a couple of weeks ago on my dropbox. Loaded it up. Mapper loads fine and works just fine. Exported those scripts/triggers/aliases to my main profile and installed. Still the same settings issue. I haven't made any changes in the last two weeks with 'settings' so I don't think it's a duplicate variable issue. The only reference to settings per a search is in the Mudlet Mapper files. Next thing I did was literally copy the files in the test profile that was working into my main profile... still the same error. Leads me to believe that something -is- wrong with a variable or something in this profile, but I have no idea where to look.

    [ERROR:] object:<error in anonymous Lua function> function:<no debug data available>
             <Lua error:[string "local downloadfolder = getMudletHomeDir()....."]:25: attempt to index 
    field 'settings' (a nil value)>

    Second line is the line it is erroring on when I login:

    if mmp.settings.crowdmap and and == "achaea" then

    downloadFile(mmp.mapfile, "") -- Line 25

    elseif mmp.settings.updatemap then

    downloadFile(mmp.mapfile, "http://www."".com/maps/MD5SUM")


  • Just exported my profile to a fresh one and updated mapper there. Worked fine with the default mapper script there... then it updated and started throwing errors again. I think it's a bad download. @Vadimuses

  • AhmetAhmet Wherever I wanna be
    Dunn said:
    Just exported my profile to a fresh one and updated mapper there. Worked fine with the default mapper script there... then it updated and started throwing errors again. I think it's a bad download. @Vadimuses
    I had this issue and toggling a random mconfig setting fixed it :(
    Huh. Neat.
  • mconfig won't even show up for me. Get the settings error for everything.

  • Now I'm getting the error:

    [ERROR:] object:<lua command> function:<Alias100>
             <[string "-- mmp = mudlet mapper namespace..."]:101: attempt to index field 'ferry_rooms' 
    (a nil value)>

    I forced the startup script to run as it seemed to be returning per the below condition:

    function mmp.startup()

    if not mmp.firstRun then



    mmp.settings wasn't being defined before as it is supposed to be in the mmp.startup script. Forcing it to run defined it, but now I've hit the above. Thoughts? It's becoming a rabbit hole of a debug.

  • Show the first error you hit when you open your profile that's related to the mapper, that'll help give a clue.
Sign In or Register to comment.