Welcome to the Achaea Forums! Please be sure to read the Forum Rules.

Mudlet 2.1 on Ubuntu 13.04

SherazadSherazad Planef UrthMember Posts: 956 @ - Epic Achaean
I did a clean install and then I got this message when I started a profile:

[ ERROR ] cannot find Lua module zipLua error:[string "require "zip""]:1: module 'zip' not found:
no field package.preload['zip']
no file './zip.lua'
no file '/usr/local/share/lua/5.1/zip.lua'
no file '/usr/local/share/lua/5.1/zip/init.lua'
no file '/usr/local/lib/lua/5.1/zip.lua'
no file '/usr/local/lib/lua/5.1/zip/init.lua'
no file '/usr/share/lua/5.1/zip.lua'
no file '/usr/share/lua/5.1/zip/init.lua'
no file './zip.so'
no file '/usr/local/lib/lua/5.1/zip.so'
no file '/usr/lib/i386-linux-gnu/lua/5.1/zip.so'
no file '/usr/lib/lua/5.1/zip.so'
no file '/usr/local/lib/lua/5.1/loadall.so'
[ ERROR ] cannot find Lua module lfs (Lua File System).Lua error:[string "require "zip""]:1: module 
'zip' not found:
no field package.preload['zip']
no file './zip.lua'
no file '/usr/local/share/lua/5.1/zip.lua'
no file '/usr/local/share/lua/5.1/zip/init.lua'
no file '/usr/local/lib/lua/5.1/zip.lua'
no file '/usr/local/lib/lua/5.1/zip/init.lua'
no file '/usr/share/lua/5.1/zip.lua'
no file '/usr/share/lua/5.1/zip/init.lua'
no file './zip.so'
no file '/usr/local/lib/lua/5.1/zip.so'
no file '/usr/lib/i386-linux-gnu/lua/5.1/zip.so'
no file '/usr/lib/lua/5.1/zip.so'
no file '/usr/local/lib/lua/5.1/loadall.so'
[  OK  ]  -  Lua module sqlite3 loaded
[  OK  ]  -  mudlet-lua API & Geyser Layout manager loaded.

I think I tried to fix this before, but the forums search thing is so bad and I forgot how to fix. >.> Halp please?
Bleh, work ate my gaming life.
내가 제일 잘 나가!!!111!!1


Tagged:

Comments

  • EldEld Member Posts: 3,946 @@ - Legendary Achaean
    Make sure you have the "lua-zip" package installed.
    SherazadHegua
  • SherazadSherazad Planef UrthMember Posts: 956 @ - Epic Achaean
    I guess this is the lua zip package thingy? xD I forgot. I did this and yay it worked.

    2. Installing the needed packages

    sudo apt-get install build-essential qt4-dev-tools lua5.1 liblua5.1-0-dev libpcre3-dev libboost-dev zlib1g-dbg zlib1g-dev libyajl2 \
    libyajl-dev libyajl2-dbg liblua5.1-rex-pcre0 liblua5.1-sql-sqlite3-2 libphonon-dev libhunspell-dev libzzip-dev liblua5.1-zip0 \
    liblua5.1-filesystem0
    Bleh, work ate my gaming life.
    내가 제일 잘 나가!!!111!!1


  • HeguaHegua Member Posts: 160 ✭✭✭ - Distinguished
    edited May 2013
    Specifically, liblua5.1-zip0 for the zip module and liblua5.1-filesystem0 for the lfs module.
    Sherazad
  • SherazadSherazad Planef UrthMember Posts: 956 @ - Epic Achaean
    Hegua said:
    Specifically, liblua5.1-zip0 for the zip module and liblua5.1-filesystem0 for the lfs module.
    Does that mean I don't have to install all of those?
    Bleh, work ate my gaming life.
    내가 제일 잘 나가!!!111!!1


  • HeguaHegua Member Posts: 160 ✭✭✭ - Distinguished
    Sherazad said:
    Hegua said:
    Specifically, liblua5.1-zip0 for the zip module and liblua5.1-filesystem0 for the lfs module.
    Does that mean I don't have to install all of those?
    Judging by the error messages in the OP, those two packages were the only ones missing.
    Sherazad
  • SherazadSherazad Planef UrthMember Posts: 956 @ - Epic Achaean
    Thank you so much! :D 
    Bleh, work ate my gaming life.
    내가 제일 잘 나가!!!111!!1


    Hegua
  • EldEld Member Posts: 3,946 @@ - Legendary Achaean
    Oops, missed the lfs message when I read this the first time.
    SherazadHegua
  • SherazadSherazad Planef UrthMember Posts: 956 @ - Epic Achaean

    Bleh. Restarting my mudlet, now on Xubuntu 14.04. I´m having the same problem, except when I try to install what was missing, I get this.

    [email protected]:~$ sudo apt-get install liblua5.1-zip0 liblua5.1-filesystem0
    Reading package lists... Done
    Building dependency tree      
    Reading state information... Done
    Note, selecting 'lua-filesystem' instead of 'liblua5.1-filesystem0'
    E: Unable to locate package liblua5.1-zip0
    E: Couldn't find any package by regex 'liblua5.1-zip0'

    Does anyone know what else I can do? I can´t really use Windows on my slow netbook.


    Bleh, work ate my gaming life.
    내가 제일 잘 나가!!!111!!1


  • HeguaHegua Member Posts: 160 ✭✭✭ - Distinguished

    The transitional packages are no longer available as of 14.04 it appears. Installing lua-filesystem and lua-zip should hopefully get you sorted.

    Sherazad
  • SherazadSherazad Planef UrthMember Posts: 956 @ - Epic Achaean

    Thanks! Working again!

    Bleh, work ate my gaming life.
    내가 제일 잘 나가!!!111!!1


    Hegua
  • SherazadSherazad Planef UrthMember Posts: 956 @ - Epic Achaean

    @Rispok‌ I'm not if you can use this, it sounds similar to what you said. 

    Bleh, work ate my gaming life.
    내가 제일 잘 나가!!!111!!1


    Rispok
Sign In to Comment.