Welcome to the Achaea Forums! Please be sure to read the Forum Rules.

Mudlet and Linux mint?

BoosteyaBoosteya Member Posts: 414 ✭✭✭ - Distinguished
I was hopeful that I could figure out how to make it work. I was wrong. :(

I can load mudlet up, but I have no Lua? *confused*
Miin-aan baash kimini-sij-i-gan bitooyin sij-i-gan-i bukwayszhiigan = blueberry π

Comments

  • StriaxStriax Member Posts: 3
    Hey what version of Linux mint are you using? I am running Linux Mint 19.3 and lua works fine in Mudlet using the binary haven’t tried to compile for source though.
  • ArchaeonArchaeon Ur mums house lolMember Posts: 1,473 ✭✭✭✭✭ - Grand Achaean
  • UtianimaUtianima Norway and AustriaMember Posts: 321 ✭✭✭✭ - Eminent
    Works fine for me with the AppImage file. I am using Ubuntu MATE, but shouldn't make a difference since it should all be contained within AppImage without need for dependencies.

    Can you share the error you're getting, or a screenshot?

    There is a great Mudlet community on Discord btw. Might be a better place to ask.

  • BoosteyaBoosteya Member Posts: 414 ✭✭✭ - Distinguished


    Miin-aan baash kimini-sij-i-gan bitooyin sij-i-gan-i bukwayszhiigan = blueberry π
  • BoosteyaBoosteya Member Posts: 414 ✭✭✭ - Distinguished
    edited February 2020
    Notes: not sure what version of mint. Never used mint before. Came preinstalled on a gift of a secondhand computer. Am very grateful; this is my only working comp right now.

    I did dl Lua the way I would have for ubuntu. No change. I wasn't able to add the mudlet PPA despite there being strong signs that I should have been able. Is this a concern or is there a reason for that?

    Edit: I thought mudlet version was older than it seems to say it is.

    Edit2: Thank you guys!
    Miin-aan baash kimini-sij-i-gan bitooyin sij-i-gan-i bukwayszhiigan = blueberry π
    Utianima
  • VinzentVinzent Member Posts: 362 ✭✭✭ - Distinguished
    It depends on the version of Mint being used, but PPA is not supported in LMDE. Working without a PPA means the process of updating Mudlet (or other programs not supported in a canonical repository) is more manual; it's a loss of convenience not a compromise to functionality.

    As @Utianima said, the AppImage format is a run-anywhere format that includes all dependencies, except not really. It includes all dependencies not included in the target system. What you appear to be missing or having trouble with is the formatting lcf module for Lua.

    First is to make sure LuaRocks is installed. Enter 'luarocks' in a terminal and if you get a list of commands back we can move on. If not, you can install it via Mint's software center (don't remember the exact name) program.

    Second is to try and install lcf over what already exists, if anything does at all. Enter 'luarocks install lcf' in a terminal and follow the process. After this, Mudlet might not have the same issue anymore.

    You can also download the latest version of Mudlet and see if that fixes the problem by itself.
    Utianima
  • BoosteyaBoosteya Member Posts: 414 ✭✭✭ - Distinguished
    Yeah, I needed luarocks. Okay, time to test... *inhale*
    Miin-aan baash kimini-sij-i-gan bitooyin sij-i-gan-i bukwayszhiigan = blueberry π
    Utianima
  • VadimusesVadimuses Member Posts: 1,132 @ - Epic Achaean
    Use Mudlet 4.6, which is the image, and lcf will be there.
Sign In to Comment.