NightfallUI (Free Mudlet GUI and Script Suite)



  • I am I am loving this, but also having a couple of issues:
    1.  my chat section remains empty no matter who says what or where,
    2. The health and mana bars (as well as the Rage count) seem to be cut off by something,
    3. The skills bar (which has the potential to be my favorite part) won’t let me enter anything.  I think that perhaps I am missing a step, it tells me I have to “run AB first” and I have tried several combinations of the AB command (AB weaponmastery, ab duality, ab weaponmastery duality, etc.)
    I have zero Mudlet or coding experience (which is one of the main draws of your interface for me as I try to switch from Nexus), so I’m sure I’ve just forgotten something here.  I am running svof and mapper in addition to this, if they have any play here.

    And since we’re on the topic, is there anyway to integrate a battlerage tracker into this?  Any recommendations for a good one?
  • I am having these issues as well.
  • edited December 2018
    1) YATCO is what does the chat. Sometimes it gets messed up with window size changes and the input box getting too big. Simply type: fixchat. It also needs to be configured, where you setup the triggers to put stuff in the appropriate tabs, check out the triggers settings and navigate to the yatco folder to see an example.

    2) it has to do with font sizing. Search previous posts in this thread for how to fix. Basically the code that redisplays those GUI widgets has hardcoded font sizes even after you configure it (via typing: nightfall, then clicking on "[gui options]", and then changing font sizes there.)

    3) Not sure about this one, I don't use it myself. I's still on the fence about keeping it around and figuring it out and simply removing it to get those 3-4 lines of text back.

    You can certainly add a battlerage tracker yourself. I recommend just using the Bashing script though and displaying in the sidebar what it is doing since it does a really good job itself. 
  • No matter what I do I cannot get the font to install correctly for whatever reason and just can't figure it out.
  • edited January 2019
    Sorry I haven't responded sooner. I haven't played since last year as I got turned off from the game for various reasons so I'm not playing anymore. I'm happy other people have been able to troubleshoot this though. I may come back at some point but not at this time

  • Im loving it, and I have modified the hell out of it. Its clean and easy hope you come back soon @Brenex
  • First of all, thank you Brenex and everyone else who contributed to make such a great GUI! It really made the switch from Nexus a lot smoother.

    I am suddenly having trouble with the Chat window and the Combat window not displaying anything when it should. Both were working until recently.

    Here is what it looks like:

    Typing "fixchat" did correct the placement of the chat window (it was behind the map at first, but now it snaps to the bottom right as it should) but Tells, CTs, etc do not appear in the chat window.

    As you can see, Targetting through the NightfallUI does work and the color of the targetted denizen changes to mint upon clicking again, but in the Combat Tab, Target is set to None and the HP % of the target does not appear. 

    1. Erased the Achaea profile for mudlet and did a fresh reinstall of all the packages (from and
    2. "fixchat" did not resolve the issue of the chat window not working, although it did fix the placement of the chat window
    3. I thought both problems might stem from gmcp so I turned gmcp off and on through mudlet settings (though ih works fine...)

    None of these fixed the problems that I am having with both the Chat window and the Combat window. 

    Any help would be greatly appreciated! Thank you!
  • Help please. How can I fix this?
  • @Fendrel Tried it just now ... same thing happened to me. Shame.
  • Try resizing the window, does that fix it?
  • Anyone able to help me out. When it downloads it looks fine, but:

    1) every time I move or chat my two sides turn completely black. I tried "fixchat" and that works .... until I move again and then it goes black. I did make sure I have the font downloaded, which seemed to be the reason for others

    2) My affliction tracker doesn't seem to update at all but all other info does :S
  • Edit: So if I change the border widths under Mudlet settings, it fixes my first issue, however, I need to manually change this each time I log on... Any reason mudlet won't save these settings for me even though I hit save??

    2) BUT map and my affliction tracker still not working :(
  • After working beautifully for quite awhile, this suddenly happened in the middle of play. It was weird, because I didn't reload anything or open and close Mudlet. I was sitting around fishing and boom, HP bar spillage.

    Does anyone know a fix for this? It's my favorite UI. :(

  • You will want to find the script called "gmcp.Char.Vitals"

    Find this line:

    nightfallUI.char.hp_bar_gauge:setValue(nightfallUI.char.myhealth, nightfallUI.char.mymaxhealth)

    And change it to this:

    nightfallUI.char.hp_bar_gauge:setValue(nightfallUI.char.myhealth, math.min(nightfallUI.char.mymaxhealth,nightfallUI.char.myhealth))

  • Has anyone's Combat tab broken, and how did you fix it?

Sign In or Register to comment.