Welcome to the Achaea Forums! Please be sure to read the Forum Rules.

Shooting Reflex

KresslackKresslack Florida, United StatesMember Posts: 6,247 @@ - Legendary Achaean
For some reason that evades me, my shooting reflexes for archery have partially stopped working. I have an alias for aiming in a direction, and a trigger to fire off a successful aim. Only the aiming is working for some reason.

How do I correct this?

Alias:

Trigger:




Comments

  • ArchaeonArchaeon Ur mums house lolMember Posts: 356 ✭✭✭ - Distinguished
    So there's no matches[2] in the trigger.  If you want to keep it like that, set a variable to your shootdir, and use that.  For instance, your trigger should be
    send("shoot "..t.." "..shootdir[dir])

    and on your alias you should have 
    dir = matches[2]
    Kresslack
  • KresslackKresslack Florida, United StatesMember Posts: 6,247 @@ - Legendary Achaean
    Ah, ok, I'll give that a try soon as I can. Thank you.


  • AccipiterAccipiter Member Posts: 457 ✭✭✭✭ - Eminent
    Is there a reason you are converting the direction into long form?
  • KresslackKresslack Florida, United StatesMember Posts: 6,247 @@ - Legendary Achaean
    Accipiter said:
    Is there a reason you are converting the direction into long form?
    Oh, because I think I repurposed this from my ship turning alias, which I use the conversion to actually say the direction I'm turning when commanding the ship (for immersion).


  • PyoriPyori Member Posts: 1,734 @ - Epic Achaean
    edited May 27
    Archaeon's isn't gonna work since shootDir is local to the alias.

    1) Add shootingDir = shootDir[matches[2]]
       shootingDir = matches[2] would work as well
    2) Then change the trigger to do send("shoot "..t.." "..shootingDir)


    Archaeon
  • ArchaeonArchaeon Ur mums house lolMember Posts: 356 ✭✭✭ - Distinguished
    yeah i skipped over the local.  But in any case, my suggestion would be to drop the direction altogether, and don't aim.
Sign In to Comment.