Welcome to the Achaea Forums! Please be sure to read the Forum Rules.

Theft Question

TherisTheris ✭✭✭ - DistinguishedMember Posts: 76 ✭✭✭ - Distinguished
Question: since the pickpocket change, is the inability of serpents to force you to give/drop gold hard-coded, or is that just "against the rules" now? I had a theft attempt that looked quite a bit like the old theft recently--the serpent snapped, I moved a few rooms away (voluntarily), I removed gold from pack, and then I got a message like "I do not see that being here," as though I had tried to hand off the gold.

I know this is probably a pretty old change, but I just came back after a very long absence. I saw the announce post, but it didn't really answer my question. Any additional explanation about the newer theft system would also be appreciated.

Comments

  • TectonTecton The Garden of the GodsAdministrator Posts: 2,507 Admin
    It is hardcoded, yes.
    Theris
  • SenaSena Member Posts: 3,957 @@ - Legendary Achaean
    Forcing the commands "give", "drop", "put", "throw", and maybe one or two others are completely impossible now, aside from some exceptions for combat reasons (such as putting vials away).

    Generally, the serpent will force you to get your gold out, drop your selfishness if you have it, and then they'll pickpocket you. A good thief will time it so the pickpocket completes just as you get the gold out or just as you drop selfishness, giving you as little time as possible to react.
    Theris
  • AddamaAddama ✭✭✭✭✭ - Grand Achaean Member Posts: 947 ✭✭✭✭✭ - Grand Achaean
    You can still be forced to put gold into a hat that is on the ground, but I've only seen that done by Occultists.
    ~Kresslack's obsession~
  • IocunIocun Member Posts: 3,506 @@ - Legendary Achaean
    I find that difficult to believe. If you've actually seen this happening, it's a bug and should be reported.
    KresslackMelodie
  • BadeBade ✭✭✭ - Distinguished Member Posts: 114 ✭✭✭ - Distinguished
    Its a bug? I thiugh occultists could still steal this wat, like giving you a hat and getting you to put your gold in the hat.
  • HeroseHerose ✭✭✭ - Distinguished Nova Scotia, CanadaMember Posts: 89 ✭✭✭ - Distinguished
    edited November 2014
    You definitely can't get them to put things in a hat if the hat is in their inventory.  Haven't tried it if it was on the ground though.
  • AddamaAddama ✭✭✭✭✭ - Grand Achaean Member Posts: 947 ✭✭✭✭✭ - Grand Achaean
    edited November 2014
    Jinsun was doing it as of two months ago, unless something has changed you can still do it.

    E: The hat must be on the ground.
    ~Kresslack's obsession~
  • KresslackKresslack Florida, United StatesMember Posts: 6,301 @@ - Legendary Achaean
    It's Jinsun...don't follow Jinsun's example. Sounds like a bug, so trying to loophole it is pretty risky.


    MannimarShirszae
  • JinsunJinsun TN, USAMember Posts: 2,927 @@ - Legendary Achaean
    Kept up a bit with this thread. No one should follow my example. I'm a bad guy, but you can't use soulmaster/hat to steal anything but pipes or vials. I've been asked by the admin to stop doing so, even though there is no current rule against it. Anyone that is telling you that I'm stealing gold/keys/anything besides pipes and vials lied to you.
    image
    Stuneree
Sign In to Comment.