Welcome to the Achaea Forums! Please be sure to read the Forum Rules.

Mudlet 3 in Arch Linux (Antergos)

MamiMami Posts: 82Member ✭✭✭ - Distinguished
I tried running the .run file for Mudlet 3 in Antergos, but it doesn't appear. When I do it on the terminal, this appears:

[mami@AntergosDudels ~]$ /home/mami/mudlet-3.0.0-delta/bin/run-mudlet.sh
./mudlet: error while loading shared libraries: libicui18n.so.52: cannot open shared object file: No such file or directory
[mami@AntergosDudels ~]$ 

I don't really know what this means. Help pls.
Tagged:

Comments

  • TectonTecton The Garden of the GodsPosts: 2,485Administrator @@ - Legendary Achaean
    Try "pacman -S icu"
    Mami
  • MamiMami Posts: 82Member ✭✭✭ - Distinguished
    Still the same :s

  • JaceroJacero Posts: 37Member ✭✭ - Stalwart
    What you can do instead, @Mami, is grab lrexlib-pcre5.1, lua51-sql-sqlite, luazip5.1, and mudlet-git from the AUR and use makepkg to compile and install them.
    Mami
  • MamiMami Posts: 82Member ✭✭✭ - Distinguished
    I tried this on package manager:

    on the aur but it said error: target not found: mudlet-git
    same with mudlet-dev.
  • JaceroJacero Posts: 37Member ✭✭ - Stalwart
    edited March 2016
    Here, I've written a shell script that'll do the work for you. Just copy this into a file, make it executable (chmod +x filename), and then run it like this: ./filename. This script assumes base-devel, bash, and git is installed.
    #!/usr/bin/env bash
    
    packages=('lrexlib-pcre5.1' 'lua51-sql-sqlite' 'luazip5.1' 'mudlet-git')
    
    for pkg in "${packages[@]}"; do
        git clone https://aur.archlinux.org/"$pkg".git
        cd "$pkg"
        makepkg -si
        cd ..
    done
    This will clone the repositories of the four packages in the array, ask to install dependencies, compile the package, ask to install the package, then move on to the next package and start over.

    E: Forgot to tag h(er|im). @Mami
    Mami
  • MamiMami Posts: 82Member ✭✭✭ - Distinguished
    I will try it in a bit. What's the diff between git and dev mudlet? Wow thanks
  • JaceroJacero Posts: 37Member ✭✭ - Stalwart
    edited March 2016
    mudlet-dev downloads and compiles a tarball (http://www.mudlet.org/download/Mudlet_3.0.0-delta.tar.bz2) which is a snapshot of the Mudlet repository from a while ago. This might be more stable then the git version.

    mudlet-git clones the Mudlet repository (https://github.com/Mudlet/Mudlet/) and compiles the absolute newest available version (which may include bugs). I currently use this one and haven't had any issues with it. Your milage may vary.

    It's up to you, but you can replace the mudlet-git with mudlet-dev if you want.
    Mami
  • MamiMami Posts: 82Member ✭✭✭ - Distinguished
    Wewt thanks! Working now yay! Wine also works but it is too ugly compared to mudlet-git.
Sign In to Comment.